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 Windows (3.0.5 and later): Every time I launch Photoshop

I get a message saying the scratch disk is full, and it doesn’t

start. I have tons of free space on another drive, but before

I can designate which scratch disk to use, Photoshop shuts

down. Is there any way around this?

Yes. First of all, you can, and probably should, free up some

space on the boot drive (even if you’re not having trouble with

your Photoshop scratch disk, lack of disk space may also make

other programs behave erratically). By default, Photoshop will use

your boot drive (usually C:) for the scratch disk, until you tell it to

use something else. If your boot drive is crammed full, it can pre-

vent Photoshop from launching, and of course if you can’t launch

Photoshop, you can’t tell it to use a different scratch disk. But

there is an easy way out of this catch-22. To force Photoshop to

use a different scratch disk as it starts up, just hold down Ctrl and

Alt immediately after you launch Photoshop from the Start menu;

after a moment you should see the Memory Preferences dialog

box, in which you can designate your scratch disk. Timing is very

important as you press these keys; doing so too early cancels the

launch (in Windows 95) or brings up the program file’s properties

(in Windows 3.1), and too late is, well, too late.

After you change the settings in your Memory Preferences dia-

log box, you should be able to launch successfully. The settings

you specify will “stick” until you make a further change. (See the

last question in the next column for more information about

scratch disks.)

Windows/Mac: Why can’t I define a pattern in Photoshop?

Probably a simple matter of settings. By definition, a pattern

shape must be rectangular, so make sure you’re using the rectan-

gular marquee tool—and make sure its Feather setting is 0 (zero).

If you have any doubts about your settings, you can choose Reset

Tool from the Marquee Options palette. This should restore all the

marquee tool’s settings to the factory defaults.

To use the Pattern feature, select the rectangular marquee tool,

select the area that you want to use as your base pattern, choose

Define Pattern from the Edit menu, choose Fill from the same

menu, and then choose Pattern from the Use pop-up menu.
Windows: Photoshop has started doing something really

weird—when I switch tools, the cursor displays the previous

tool’s icon. The newly selected tool works correctly, but see-

ing the previous icon is driving me nuts—help me, please!

Help is on the way. This problem is almost certainly caused by

your video driver; we hear about it most often from users who

have STB Velocity or Number Nine Revolution 3D video cards
(though it could occur with others as well). You need an updated

video driver from the manufacturer of your video card or your PC.

If your STB video card came with your Dell or Gateway PC, call the

vendor’s customer support line (Dell at 888-560-8324 or Gateway

at 800-846-2000). If you purchased your video card separately

from your computer, contact STB Customer Support at (972) 669-

0989 or check STB’s Web site (www.stb.com/drivers/velocity/vl128.

html). If you have a Number Nine Revolution 3D video card, con-

tact Number Nine Technical Support at (781) 869-7214.

Windows/Mac (4.0 only): I know that Photoshop can embed

an invisible watermark into any image I create, one that’s

detectable even after the image has been printed and

scanned. But I’ve heard that traceable, “unrequested” infor-

mation (such as my name, serial number, registration info,

and so forth) is also embedded into all my images. Is this

true, or is it another urban, I mean cyber, myth?

Don’t worry—there aren’t any alien implants in your Photo-

shop documents. This is, as you have suspected, nothing more

than an unfounded rumor.

As the author of Photoshop images, you have the option of

adding a digital watermark to your files using Digimarc’s Picture-

Marc technology (you can then register your watermark, for a fee,

in an online database). This digital watermark, which you can

make visible or invisible, can contain copyright information as

well as provide viewers with a way to contact you—if you choose

to include it. For more information about this process, you can

contact Digimarc at (800) DIGIMARC or (503) 626-8811, or on the

Web at www.digimarc.com.

We stress that these options are used only if you specifically set

them up: no private (or even public) information gets embedded

in your Photoshop files unless you take specific steps to include

it; Photoshop does not add any information about you or your

computer to any files without your explicit request.

Windows/Mac: Are there any limits to the size of images

I can work on in Photoshop?

In many respects the only limits on Photoshop are your imagi-

nation and your time. However, if you’re inclined to work on very

large images, you may eventually run up against a few practical

hurdles. Here are some of the limits you could potentially encoun-

ter in Photoshop if you tend to push things to the extreme.

• Images cannot exceed 30,000 pixels along either axis (check

this number by choosing Image Size from the Image menu).

• Files cannot exceed 2 GB. This is true for any file that Photo-

shop uses: the image itself as well as any related scratch-disk

files. Remember that whenever you’re working on an image,

one or more scratch-disk files (which are, essentially, tempo-

rary files that Photoshop uses to perform a variety of opera-

tions) are written to a designated hard disk. (See the related

question on scratch disks, above left.) The scratch-disk space

that’s required will vary according to several factors, but de-

pends primarily on how large your Photoshop image file is. As

a rule of thumb, you can anticipate that Photoshop will require

scratch-disk space that’s roughly three to five times the size of

your opened (that is, uncompressed) image; for bitmap mode

images, it can require up to ten times the file size.

• Files can contain a maximum of 99 layers (including adjust-

ment layers), plus one Background layer.
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• Files can contain a maximum of 24 channels.

It’s unlikely that any of your Photoshop files will even come close

to, let alone exceed, these limits. Realistically speaking, given

these numbers, you’ll probably find that your hard-disk space,

RAM, or perhaps the time you have to spend on the project will

give out well before you reach any of Photoshop’s built-in limits.

Windows/Mac: Is there an easy way in Photoshop to remove

that hideous red-eye phenomenon that seems to afflict all

photos of my boyfriend?

When you take flash photos of your boyfriend at too-close

range, the flash will sometimes reflect back from his eyes, which

results in an unattractive—some would say demonic—“red-eye”

effect. Fortunately it’s usually not hard to correct in Photoshop.

Here’s one way.

1. Open the Color Range dialog box (choose Color Range from

the Select menu) and position it so that you can see the sub-

ject’s eyes as well as the dialog box. (You may want to do a

rough selection around the eye area using the lasso tool before

you start.)

2. Select Sampled Colors from the Select pop-up menu and None

from the Selection Preview pop-up menu. Set the preview type

to Image (not Selection).

3. Click on the target eyedropper (the leftmost of the three eye-

dropper tools in the Color Range dialog box) and click in the
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resulting selections

target eyedropper
red area of the subject’s eyes (either in the image itself or in the

image preview within the Color Range dialog box). Change the

Selection Preview option to Grayscale and check to see how

you did. Your selection should appear white, and should corre-

spond to the red areas in the eyes.

To capture exactly the area you want, switch back and forth

between the image and the selection by changing between

Grayscale and None in the Selection Preview menu. (In Photo-

shop 4.x, press Ctrl (Windows) or Command (Macintosh) to

toggle between preview modes.) Adjust the selection with the

Fuzziness slider; lower Fuzziness values restrict the selection to

the specific pixel values you chose with the eyedropper, while

higher fuzziness values extend the selection to pixels similar in

value to the ones you chose.

If necessary, you can also use the plus or minus eyedroppers

in the Color Range dialog box to increase or decrease the selec-

tion of sampled pixels. By then adjusting the Fuzziness, you

should be able to isolate the red pixels in the eye without se-

lecting non-red pixels.

4. When you’re satisfied that you’ve got a good selection, click OK

to exit the Color Range dialog box. You should now have a se-

lection of the red-eye pixels based on their color values.

You might want to save your selection in case you need to

come back to it later; to do so, choose Save Selection from the

Select menu and click OK to create a new channel containing

your selection.

5. Paint, clone, or fill your selection with colors more appropriate

for a human eye.

If you have multiple photos with the same red-eye problem and

you want to be able to reuse the same Color Range settings, you

can save your settings (click the Save button in the Color Range

dialog box and type an appropriate name for your settings file)

and reload them later.

Windows/Mac: I’m interested in writing plug-ins for Photo-

shop. Where can I find more information?

Great—we all love plug-ins. There are two ways you can create

your own plug-in modules for Photoshop. For simple plug-ins,

you can use the Filter Factory, a filter for creating—you guessed

it—stand-alone Photoshop plug-ins. (In this case, by “simple” we
As you can see, photographic
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Micro Tip

Use the polygon

lasso tool to make

straight-edged selec-

tions: Click in your

image and play

“connect the dots.“

You can back up one

point at a time by

pressing Delete. (In

Photoshop 3.x, hold

down Alt or Option

while clicking and

dragging the lasso.)

Tip: Windows/Mac
mean a plug-in (or filter) that allows you to make “exterior” or cos-

metic changes to all or any of an image’s channels to alter its ap-

pearance.) You can find the Filter Factory on your Photoshop CD,

though it’s not installed automatically. (In Windows, look in the

Goodies folder for Photoshop 3.x or the Plug_ins subfolder of the

Goodies folder for Photoshop 4.x; on the Macintosh, look in the

Other Goodies folder for Photoshop 3.x or the Optional Plugins

subfolder of the Other Goodies folder for Photoshop 4.x.) There

are many Filter Factory enthusiasts on the Web with whom you

can find and share information—and, of course, filters. To create

plug-ins for more involved functions (that is, something more

complex than changing the look of your image), you’ll need a

knowledge of programming and the Photoshop Software Devel-

opment Kit (SDK). The SDK is available on the Photoshop CD. In

Windows, look in the Ps30Xsdk subfolder (where X is the dot-re-

lease version number) of the Devinfo subfolder of the Techlib

folder for Photoshop 3.x or the Ps4_sdk subfolder of the Devinfo

subfolder of the Techinfo folder for Photoshop 4.x; on the Mac-

intosh, look in the Technical Library folder for Photoshop 3.x or in

the Developer Support subfolder of the Adobe Technical Info

folder for Photoshop 4.x.

To see a good example of a shareware plug-in made with the

SDK, you can take a look at Blade Pro 2.0.8, from Flaming Pear,

which helps you create (and illuminate) realistic 3D objects, text,

and buttons. (You can find Blade Pro on the Web at ccn.cs.dal.ca/

~aa731/blade.html.)

If you’re going to get into writing plug-ins for Photoshop (or

any Adobe application, for that matter), be sure to check out

the Adobe Developers Association (ADA) online at www.adobe.

com/supportservice/devrelations/main.html. The ADA can provide

you with additional technical information, support, and a variety

of resources for developing plug-ins, including, of course, the lat-

est version of the SDK.

Windows/Mac: I’m having trouble outputting duotones. The

separations I get look like they’re identical. What’s wrong?

Possibly nothing. Duotone plates often don’t look noticeably

different from each other—especially on proofs printed from

your desktop laser printer. Examine them closely to make sure

you really are getting two identical plates. If you’re not sure that

your plates contain different data, try this test: make some drastic

changes to one of the duotone curves, and then print the seps

to see if the plates differ. (Save your image file first, though, with

the “real” curve, so that you can return to your original settings af-

ter you’ve tinkered with your image.)

To change the duotone curve, choose Duotone from the Mode

submenu of the Image menu (in Photoshop 3.x, choose Duotone

directly from the Mode menu) and click one of the small curve

squares in the left column in the Duotone Options dialog box.

Click directly on the curve to add some points, and drag them up

or down to create some drastic peaks and valleys. Click OK twice

to get back to your image; you should see some radical (and likely

ugly) changes. Try printing the document again, and it should be

obvious if you are getting different data on the two plates.

By default, no matter how you create your duotone, the plates

will always print with different screen angles, to prevent moiré

patterns and other visual disharmony. But there may be times

when you’d want to customize the screen-angle settings for sepa-

rations. The Duotone Presets that come with Photoshop (which
you can load through the Duotone Options dialog box discussed

above) include their own appropriate settings. If you’re using

these presets, you usually won’t have to make changes to those

settings. (The Duotones folder is located in your Photoshop folder

in Windows; the Duotone Presets folder is located in the Goodies

subfolder of your Photoshop folder on the Macintosh.)

If you’ve consulted with your commercial printer and you

know you want to make a change, you can type in your own cus-

tom angle values: Choose Page Setup from the File menu, and

then click Screens (Windows) or Screen (Mac) to get into the Half-

tone Screens dialog box. Deselect Use Printer’s Default Screens

and type in appropriate values. Be aware, however, that the

angles you type into the Halftone Screens dialog box will “stick”;

even if you subsequently load a duotone preset for that image,

your manually entered screen-angle values will stay loaded until

you type in new ones, which may cause a bit of havoc with the

presets. If you need more detailed information on using custom

halftone screen angles, consult with your commercial printer.

One final note: If you’re saving the duotone file for use in a

page-layout program—that is, if you’re not printing directly from

Photoshop—remember that you’ll need to save the duotone file

in EPS format (which, of course, will require a PostScript printer

for proper output). To ensure that your EPS will print as expected

from within a layout program, include custom halftone screens in

your image as described above, and be sure to check Include Half-

tone Screens in the EPS Format dialog box; otherwise, the screens

will all separate at the same angle. (In PageMaker, the imported

values may not appear accurately in the Print Color dialog box,

but the colors will print correctly.) ◆
Windows of opportunity
When a dialog box is open, you usually have to close it before

you can use other features in a program. But in Photoshop,

you can take advantage of many menu choices even while

you’re in dialog boxes.

For example, when the New dialog box is open and you

select an existing, open file from the lower part of the Window

menu, you automatically populate the New dialog box’s fields

with the settings from that existing file (with the exception of

the background color). This can come in handy when you

want to create new files whose dimensions and resolution

match your existing file.

You can use the View and Window menus to turn on and

off various features while many dialog boxes are open. For

instance, most of Photoshop’s floating palettes can be toggled

on or off via the Window menu. While in most of the image

adjustment dialog boxes (those opened from the Adjust

submenu of the Image menu), you can control items from the

View menu, allowing you to show CMYK previews and gamut

warnings, as well as turning rulers, grids, guides, and other

features on and off. Finally, you can access View menu items

from within the Color Range and some (but not all) of the

filter dialog boxes.
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